Welcome to Obscure Gamers

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

ASSEMblergames.com Archive: bug testing

EDIT: Since posting this we have decided to convert the custom system to XenForo 2.1 as it's easier to manage and enables search.
1561708840665.png

As announced awhile ago, we've built a database of all AG posts/threads thanks to Alpha and many other AG members who put help in.

This is now live at https://assembler-games.com/ but is only static, i.e you cannot login so no personal data is included nor private messages.

A few sections don't currently work, and the category's aren't shown right in the breadcrumbs, 0th bit also isn't fully added yet but it should be usable. If you find any bugs please let me know thank you!

Avatars aren't currently added, but will be in time. you may get the odd 500 error, if you do just refresh after a minute or so and it'll load. Search features will also be added in time.

Thanks again to everybody for helping!

Regards,
Damien/Demon

EDIT: Known bugs/issues.
  1. Few pages time out due to a PDO bug.
  2. Search is being coded from scratch.
  3. A cache is being added to speed up page load times.
  4. Everydrive forums was imported wrong and threads need manually changing but are all there.
  5. 0th bit needs manually importing with the last few posts of value from the live AG site.
  6. Avatars are being added. Least those that had public profiles, we couldn't grab from private profiles sadly.
 
Last edited:
It's in there, just surprisingly far back on page 10

Ah yeah, it doesn't order properly I noticed when redoing everdrive. Some "new" stuff was like 5/6 pages back or further it's odd. but if you know the original thread link adding "-" between "assembler games" so it's "assembler-games.com" it'll show. All threads should be there, minus 0th bit which is a manual import I've had no time for :(
 
Everything currently visible on the site should be (or eventually end up being) here. I'm not sure wether all content from previous incarnations has been migrated during Kev's transition to XenForo though.

edit: Come to think of it, things like wiki content (not that there was much) and user galleries aren't included, Just forum posts.
 
Am I the ony one who get always an error with this domain? Oo

I took it down while I worked on an improved version, The custom one was causing too many issues. I just need to renew the xenforo license. Been away mostly lately but it's done minus a few bugs and even uses xenforo meaning it's fully searchable as before like AG.

EDIT:
1565313333618.png
 
Last edited:
Never saw the 0th bit section. I knew something about it, but never had access for some reason. Were there like specific requirements?
 
No. You had to be deemed "part of the inner circle" by Kev, so requirements were pretty much as vague as possible.
 
No. You had to be deemed "part of the inner circle" by Kev, so requirements were pretty much as vague as possible.
Snap! Oh well, I hope at least some useful information from that board surfaces, I'm sure it's full of interesting stuff that could be useful.
 
Less interesting/useful than one would've expected imho.
The recent dump on archive.org (the one-file download, not the browsable pages) has it (minus the last few weeks, obviously).
 
Yeah it was in the Archive.org backups and the backups done by Nemesis. There's very few threads of interest and about 2000 posts I've got to convert still, along with some minor issues but it's readable which is the main thing and fully searchable, including matching id's/post id's meaning you can copy an ASSEMblergames.com link and simple add a - between ASSEMbler and games :)

Examples,
and archive version
https://www.assembler-games.com/threads/hello-from-florida.71171/ :D

Oh, and I decided to save myself $20/year by simply making my own version of AG's theme, not as flashy clearly but still good enough with both light & dark versions being made.
 
This thread has a bunch of issues with broken quotes, inline images, emotes and attachments. There's other threads with similar problems.

edit: Actually, it seems to be every thread so I guess it's simply someone's working on the whole archive right now...? If so, disregard.

edit #2: wasn't just a temporary thing after all, still broken...
 
Last edited:
It's definitely saving a lot of invaluable info, thanks a lot for this!

I have one question though, do you consider on making your IP (reverse-proxy or whatever you use) accept the original assemblergames.com URL?
I just tried after editing my hosts file and I get an HTTP 530 error with http:// assemblergames.com and ERR_SSL_VERSION_OR_CIPHER_MISMATCH with https:// assemblergames.com
 
Last edited:
It's definitely saving a lot of invaluable info, thanks a lot for this!

I have one question though, do you consider on making your IP (reverse-proxy or whatever you use) accept the original assemblergames.com URL?
I just tried after editing my hosts file and I get an HTTP 530 error with http:// assemblergames.com and ERR_SSL_VERSION_OR_CIPHER_MISMATCH with https:// assemblergames.com

Without owning the real domain it'd be a pain, more so as we use Cloudflare which needs the original IP to add a domain. We own the .net, but I'm sure something can be worked up just not a fan of exposing real server ip's as there's a few trouble makers around sadly. Maybe I can look into my own cloudflare like system but for now we'll be stuck with the - in between. I can however try mass editing the sql data to change ag.com links to redirect to a-g.com on the archive.
 
Without owning the real domain it'd be a pain, more so as we use Cloudflare which needs the original IP to add a domain. We own the .net, but I'm sure something can be worked up just not a fan of exposing real server ip's as there's a few trouble makers around sadly. Maybe I can look into my own cloudflare like system but for now we'll be stuck with the - in between. I can however try mass editing the sql data to change ag.com links to redirect to a-g.com on the archive.
Ok I see, it is not critical anyway
About editing links, maybe you can change them when the server answers instead of directly in the SQL DB, or better you could add a tiny JavaScript script doing that so that the load is in the browser side
 
Might be a good idea to re-crawl AG at some point since there's been interesting content going up in the meantime. example. It's not all shitposting over there
 
This thread has [...] issues with broken quotes, inline images, emotes and attachments [...] Actually, it seems to be every thread
Just a friendly reminder that this still hasn't been addressed. Would be nice to have a working archive, now that the original appears to finally be down. RIP un-crawled content.
 
Top