Welcome, Guest!

Here are some links you may find helpful

Dreamcast dreamcast with modded bios and gdemu. Only one game doesn't boot - driving me crazy....

bubbob

New member
Original poster
Nov 14, 2021
4
1
3
I've an old dreamcast with a GDEMU installed (old 2014 version v5.0 I bought years ago).

Today I found an envelope with a bunch of chips and parts I ordered a few years ago from Bad_Ad84's including a Dreamcast VA1 bios. So decided to install it:
-soldered a bios chip and flashed JC's DEVKIT V1.031 with dreamshell bios flasher (1.032 is not compatible with GDMenu)
-changed region from EUR/PAL to USA/NTSC to force the system to 60Hz (wire soldered at base to 12v, dreamshell region change then wire removed).

It's connected to a CRT with RGB scart cable.


Testing with around 50 games, all types including Win CE, streaming audio, protected games etc. and ALL play fine. All that is except for one game - the most common game on the system: Crazy Taxi!

Can anyone think of any reason why Crazy Taxi would not boot?


It used to boot fine so I assumed it was an issue with the bios version or region change. However I've tried writing the stock bios (It's a VA1 model so flashed v1.01d) and re-soldered the region change wire flashing the region back to EUR/PAL. Crazy Taxi is still not booting.

Tried switching from RGB scart to a composite cable and again still nothing.

Tried every version of Crazy Taxi out there (PAL, USA, JPN, full GDI versions, CDI versions), tried GDMenu region patch settings on/off, tried adding the images with madsheeps SD maker both with region patch turned on, then removed the folders and added again with region patch off. Still nothing.

Tried new SD card. Nope.


It's driving me nuts that it's just this one game not working and this is the one game everyone asks for :D
 

truemaster

Well-known member
Registered
May 31, 2019
216
164
43
well i have a genuine gdemu and crazy taxi and shenmue work fine. on pal va1 dc. use stock bios. and try updating your gdemu fw. also check your psu to motherboard conections cause those can do crazy problems
 

bubbob

New member
Original poster
Nov 14, 2021
4
1
3
I'm also leaning towards it being a flashrom issue. Although it could indeed be a power supply issue that was ultimatly the cause. It's a picoPSU with the picodreamcast. Maybe the 12V on that is dodgy when used for the region change and partially corrupted the flashrom?

I put the 12v wire back in and confirmed the region changes no problem so some aspects of the flashrom are fine.

Going to leaving the wire in and the console off until I get a serial to SD card adapter in the post and can try this fix:

It's in French but you can see what he is doing is just
-dreamshell boot loader CD image to boot from an SD card
-with these RetroDream V3.zip files from dragoncity17.free.fr/Dreamcast/RetroDream/extracted to the SD
-run the system.rom file from the SD card to flash/reset the flashrom
 

bubbob

New member
Original poster
Nov 14, 2021
4
1
3
It was a corrupt flashrom. All working now.

Steps below to fix:


01 boot DC Checker.jpg
-Disconnect the 12v flashrom write enable wire.
-Run the DC Checker disk from https://hiddenpalace.org/DC_Checker_for_MP_(Jan_12,_2000_version)


02 Red screen at boot confirms corrupt flashrom.jpg
-instant red screen confirms bad flash rom. This means any games using flashrom will not boot like crazy taxi.



03 12v flahrom write enable part 1.jpg04 12v flahrom write enable part 2.jpg
-Temporarily enable 12v flashrom write wire



05 SD card with files.jpg
-Extract the contents of this zip file http://dragoncity17.free.fr/Dreamcast/RetroDream/RetroDream V3.zip to a fat 32 formatted SD card and put it in the serial port with a dreamcast SD to serial adapter.


06 retro dream 1.jpg
-use dreamshell boot CD to boot from the SD card. This will boot RETRODREAM
-drill down to /SD/RD/FLASHROM RESET/VA1 PAL and tap A on SYSTEM.ROM to run it




07 retro dream repair flash rom.jpg
-Tap A to confirm

-At this point the flash rom is reset to PAL VA1 dreamcast (50Hz PAL). If you are on NTSC and can't display 50Hz (or you prefer 60hz), press start and choose "region change" and set USA/NTSC.

-Note that the language will be in french using retrodream's region change option so it is recommended to now power off and boot the dreamshell full boot CD and run then dreamshell region change option and set USA/NTSC/ENGLISH.

- Disconnect the 12v flashrom write enable wire.

08 region change - use dreamshell not retrodream as retrodream sets language to french.jpg
-Region changed to USA NTSC


09disconnect 12v wire and run boot checker. No red screen.jpg
-Re-run the DC Checker ISO (NOTE: Be sure to have disconnected the 12v wire before running this).
-It should run without halting at the red error screen this time indicating a good flashrom


10 crazy taxi boots.jpg
-Games requiring flashrom like Crazy taxi should now work :)


Many thanks to Cpasjuste the author of the retrodream system for releasing this utility
 
  • Like
Reactions: FamilyGuy