Welcome, Guest!

Here are some links you may find helpful

PS2 ebay PS2 doesn't read discs well

Dan12343

New member
Original poster
Jun 28, 2019
4
1
3
as title says I got a fat PS2 from ebay that doesn't read discs so well. I can hear clicking etc in the drive itself, but some games run ok

I can hear the drive clicking and sounds like a drivebelt on its way out, but it does bring most games to loading screen
but any game can't just boot without being brought to the BIOS browser\system configuration menu

what do I have to do to inspect and restore the disc drive so I don't have to buy another console?
if anybody knows of any special screwdrivers needed to perform such maintenence please let me know

or is it more worth it to just buy a working PS2 and use this one for parts?
 

Taiji_mods

Member
Jun 1, 2019
9
7
3
The PS2 uses standard philips head screws. U will need finer screwdrivers for the cd drive lid (x3 screws). I would clean out the cd drive and re grease the working parts with silicon grease. Also replace the drive belt with a new one. U will be unlikely to find a pristine PS2 in this day so it’s worth picking one up and refurbing it.
 

Mord.Fustang

Well-known member
Jun 17, 2019
50
28
18
Clean the laser to start. Also could use a multimeter and adjust the Pot(s).

Try with CD games and DVD games... does it do the same thing or only with one type?
 
  • Like
Reactions: spademytal

Dan12343

New member
Original poster
Jun 28, 2019
4
1
3
so today I opened it up and cleaned the laser with 70% rubbing alcohol on a q-tip, waited until it evaporated, then cleaned again

I got this for MGS3 online mode which now has community servers, it would load the base MGS3 game but when it launched the ELF for the online mode, the system hangs so I can't soft-reset. after cleaning it loaded twice, but when I connected the network adapter again the same thing happened

tried MK: deception, socom 1, 2, and 3, all hang the console on loading screen

tried TH pro skater 3, brings me to main menu but when I test the network settings it hangs

i had FMCB installed, ELFs won't launch or if they do they don't function correctly, loading the FTP server on ULE also hangs the system, and SMS loads infinitely. trying to run the FMCB installer on either USB or memory card also hangs the system

I even installed FMCB onto another memory card that never had it installed before on my slim PS2 (broken lid and the fix makes the console think the lid is always closed and thus I cannot launch the ELF for the MGS3 online patches) and retested all of the above

so the main problem seems to be ELF execution. is this a bad RAM or CPU issue? is something wrong when the network adapter is involved and why would that be? my old fat PS2 had its network port fried by a faulty refurbished HDD, but then it just stopped detecting the network adapter, that makes this even more confusing

i might just buy another because i was hoping i'd be able to play MGS3 online again instead of figuring out why ELFs won't execute properly, but if i can fix this i'd rather not be out of $60 and the cost for a second console
----------
UPDATE:

i narrowed it down to the network adapter, when i have the network adapter plugged in, games hang when loading, when removed, every game mentioned above loads with no problems, cleaning seems to have worked well

i bought a new network adapter, hopefully that fixes it. i just hope its the network adapter that is bad and not the port, i suppose it hangs because the console initializes the network adapter hardware but the adapter fails, i suppose if the port was bad it wouldn't initialize

very weird issue i have here yeah?
--------
UPDATE 2:

so I tested it again with\without network adapter, and when I said the game "hangs", if I remove the network adapter the game continues to load up, I can leave it in for 3 minutes and right when i remove it, the game resumes

one might say my issue here is, perhaps, obscure
 
Last edited:

truemaster

Well-known member
May 31, 2019
216
164
43
thats remind me somethin on my side is the ps2 chiped? if so freemcboot and modchip doent get along fine.(delays freezes and all that stuff) for eliminate disk read issues try load games without freemcboot pot adjust if needed. if reading from drive cant be fixed. then youre limited to load isos from either usb or internal hdd with freemcboot exploit opl game launcher and modchip disabled
 
  • Like
Reactions: bond.san

dickibow

Member
Registered
Jun 6, 2019
23
26
13
Is DNAS still involved? If so, is it a black-listed console? I’m guessing if these games are running on community servers this isn’t the problem but worth mentioning.