Welcome, Guest!

Here are some links you may find helpful

Saturn Japanese saturn picture werid

bart_simpson

Well-known member
Registered
Joined
Aug 10, 2019
Messages
53
Reaction score
6
Points
8
AG User Name
bart_simpson
AG Join Date
13/05/11
Hia I have a saturn that came in for me to repair as far as I know not modded at all
Stock Japanese system with a/v cable
And get a like if video mode is messed up or something any ideas be greatfull.
 

Attachments

  • 20210428_010223.jpg
    20210428_010223.jpg
    1.9 MB · Views: 0

segasonicfan

Active member
Joined
Jun 8, 2019
Messages
33
Reaction score
15
Points
8
AG User Name
segasonicfan
AG Join Date
Sept 23, 2011
definitely look at your chroma encoder circuit (CXA1645 near AV jack). Likely your 220uf output caps for CVBS Y, or C are going bad.

If you have an RGB or SCART cable its also a great way to rule out other issues. its an issue with your color burst (NTSC / PAL only, sometimes its also a bad clock pulse going to the encoder. Thats a lot less common tho.
 

bart_simpson

Well-known member
Registered
Joined
Aug 10, 2019
Messages
53
Reaction score
6
Points
8
AG User Name
bart_simpson
AG Join Date
13/05/11
Ah nice one thanks for your reply I will take it apart a bit later and check it over.
 

bart_simpson

Well-known member
Registered
Joined
Aug 10, 2019
Messages
53
Reaction score
6
Points
8
AG User Name
bart_simpson
AG Join Date
13/05/11
20210520_134753.jpg
 

Attachments

  • 20210520_134951.jpg
    20210520_134951.jpg
    3.3 MB · Views: 0

bart_simpson

Well-known member
Registered
Joined
Aug 10, 2019
Messages
53
Reaction score
6
Points
8
AG User Name
bart_simpson
AG Join Date
13/05/11
Plus this is with rgb
 

gorgyrip

Active member
Registered
Joined
Jun 17, 2019
Messages
42
Reaction score
11
Points
8
AG User Name
gorgyrip
AG Join Date
26 octomber 2007
I don't have experience with the saturn, but when I see this on a snes, it means i have to replace the caps after the encoder.
 

Tokimemofan

Well-known member
Registered
Joined
May 30, 2019
Messages
83
Reaction score
26
Points
18
I would check for cold solder joints first, I’ve had a few units come my way that died from taking a hard knock. If you find one there’s probably hundreds more under most of the components on the board. Best to rule that out before trying to fix a dumpster fire
 

Trimesh

Donator
Donator
Registered
Joined
May 30, 2019
Messages
238
Reaction score
207
Points
43
AG User Name
Trimesh
AG Join Date
Jul 4, 2008
Could be bad caps - could also be a bad clock synth PLL, especially if it's the square one.
 

bart_simpson

Well-known member
Registered
Joined
Aug 10, 2019
Messages
53
Reaction score
6
Points
8
AG User Name
bart_simpson
AG Join Date
13/05/11
The board is a va7 Japanese console
 
shape1
shape2
shape3
shape4
shape5
shape6
Top