Welcome, Guest!

Here are some links you may find helpful

PSBBN, FFXI and POL mirrors of KrHACKen releases?

Ioncannon

Active member
Registered
Jun 25, 2019
34
24
8
I'm the owner and lead dev of FFXIV Classic (a 1.0 emulator). Talked with a friend who was a big dev on DSP (FFXI emulator) and it sparked an interest in trying to get FFXI PS2 working again.

Haven't done much PS2 reverse engineering but was looking around the POL installer library to see if I can patch out DNAS and let the installer continue passed the verification.

Sadly the online signatures out there now are all for DNAS2. XI (at least the original installer on the first release of FFXI in US/Can) uses DNAS1 (functions are prefixed sceDNAS1____). Once my friend sends me the isos for the beta version I might make more progress as they had left the debug symbols in there.
 
  • Like
Reactions: FlamboFlaco67

Dynarec

Member
Mar 9, 2020
24
2
3
I've downloaded the PSBBN ENG 0.32 + HDDOSD image and flashed it to my HDD with HDDRawCopy 1.10 Portable, but when I try to boot to the BB Navigator my unit gets stuck at the Playstation 2 Logo screen. I am using a SCPH 50001 with an aftermarket network adapter so I can use my 1TB SATA drive.
 
Last edited:

FlamboFlaco67

Member
Jul 27, 2019
8
1
3
I'm the owner and lead dev of FFXIV Classic (a 1.0 emulator). Talked with a friend who was a big dev on DSP (FFXI emulator) and it sparked an interest in trying to get FFXI PS2 working again.

Haven't done much PS2 reverse engineering but was looking around the POL installer library to see if I can patch out DNAS and let the installer continue passed the verification.

Sadly the online signatures out there now are all for DNAS2. XI (at least the original installer on the first release of FFXI in US/Can) uses DNAS1 (functions are prefixed sceDNAS1____). Once my friend sends me the isos for the beta version I might make more progress as they had left the debug symbols in there.
i hope this comes back
 

Ioncannon

Active member
Registered
Jun 25, 2019
34
24
8
i hope this comes back

Sadly not much can be done at this point. There are two issues with the PS2 version:

1. DNAS would bind your HDD to your PS2. Because we don't know how that is done, the PS2 can't decrypt the installed copy of POL on a fresh HDD.

2. Turns out the patch files are also encrypted with a totally different method called a "DNAS Authored Binary" (iirc?). So hacking out the DNAS check on the early copies prob won't happen either.

Put that project on hold.
 
Last edited:
  • Like
Reactions: FlamboFlaco67

l_oliveira

Member
Registered
May 31, 2019
10
15
3
HDD DNAS for FFXI used a extra key which was retrieved from the DNAS server at run time. (At the time you clicked the "PLAY" button at the FFXI page inside PlayOnline viewer) and that is no longer obtainable. Lucky you I have several hot memory dumps from my PS2 running FFXI back in 2016 saved at my HDD...
 

l_oliveira

Member
Registered
May 31, 2019
10
15
3
"DNAS Authored Binary" file is a HDD DNAS file which are not yet bound to a particular harddrive. It's the format files were sent back from SONY after signing.

Tetramaster, MahJong(Janhou) and FFXI files (.pex.enc) are encrypted with an extra DNAS key which was retrieved from the DNAS service right before launch, probably to make them ultra annoying to hack (protection against cheating)
 

Casuallynoted

New member
Jan 23, 2022
1
0
1
I'm the owner and lead dev of FFXIV Classic (a 1.0 emulator). Talked with a friend who was a big dev on DSP (FFXI emulator) and it sparked an interest in trying to get FFXI PS2 working again.

Haven't done much PS2 reverse engineering but was looking around the POL installer library to see if I can patch out DNAS and let the installer continue passed the verification.

Sadly the online signatures out there now are all for DNAS2. XI (at least the original installer on the first release of FFXI in US/Can) uses DNAS1 (functions are prefixed sceDNAS1____). Once my friend sends me the isos for the beta version I might make more progress as they had left the debug symbols in there.
I was able to patch out the DNAS on the installer and get it working in an emulated environment, but it seems it still doesn't recognise that a hard disk is inserted into a physical PS2 if you're using a non-official drive. I've been told over Github that it has to do with the ATAD.irx driver, which checks to see if it is a legit Sony drive. However, in looking into the ISO's files I don't really see the ADAT.irx driver anywhere. It's possible maybe it's using a different method to verify the drive's authenticity upon boot up.