Another fundraiser..

This fundraiser is multiple lots we have been offered for our museum, most of these are extremely early systems, and many contain unreleased games and history that would other wise be lost.

The goal for this is split into groups, we have awhile to sort this one and lots would be paid as funded. The total includes paypal fee's added and shipping costs included excluding taxes, we put 10% as we're often charged different rates depending on donators locations.
Goal
£3,570.00
Received
£1,166.36
Latest donor
MSX MSX
32%
Custom LBP Developer PS3 containing multiple unreleased games, and multiple alpha builds.
£1,300.00
An early prototype PlayStation 3 dev Kit, in an early shell design which includes a disc filled with build(s? exact contents unknown)
£1,230.00
Misc Nintendo systems.
£500.00
The above prices doesn't include paypal fees, please see goal amount for total with 10% added for fee's we're charged.
£0.00
Expenses
Welcome, Guest!

Here are some links you may find helpful

Sega Katana SET 5 Power Supply Failure

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
Hello, I want to discuss with you a problem that I have in my Sega Katana.

The console needed a recap so I did it because all of the original SMD capacitors were leaking electrolytic (but the motherboard hasn't corrosion). The motherboard has two leds (one indicates if the board is receiving 5v and another 3.3v). When I turn on the console, I see only the 5v led on and the 3.3v led off, So... I asked myself if the PSU was bad.
I measured the 3 rails of the PSU, 12v rail gave 11.9v, 5v rail gave 5.1v and 3.3v rail gave 11.3mV.

Now, we know that the 3.3v rail of the PSU is failling, and you will say "Because it's a standard ATX PSU try with another PSU from any machine" and here is the problem.

I tried with different PSUs, all of them early ATX (20 pin connector) and when I try to start the katana the console doesn't turn on. The console ONLY turns on with the original PSU.

Original PSU photos:

1.PNG

2.PNG

Questions:

What shoud I do?
Shoud I have to repair the original PSU? if so, How? What could be the problem inside the PSU? I saw it and I didn't found bad capacitors.
Shoud I replace the original PSU with another one?

Thanks guys!
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
Alright, after a while I tested with another early atx power supply but the console doesn't turn on. The katana only turns on with the original PSU but as I said before, the motherboard doesn't turn on the 3.3v led. So, I should repair the original psu in order to make this thing work. I already replaced all the capacitors on both boards (main and cross products).
I'm asking for your help, what kind of advice can you give me in order to repair the 3.3v rail? Is there any expert on power supplies?

Thanks!
 

HI_RICKY

Donator
Donator
Registered
Mar 21, 2019
372
244
43
AGName
HI_Ricky
AG Join Date
Jun 7, 2007
make sure all capacitors is right + / -
I have see many case is wrong + -
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
make sure all capacitors is right + / -
I have see many case is wrong + -

I checked that before and the capacitors seems to be in right polarity. The thing is, when I turn on the console and I measure the 3.3v rail from the psu to the motherboard, it shows in my tester 11.3 mV aproximately... my question is, should the 3.3v rail supply 3.3v all the time? or should it only supply that voltage when it's under charge? if so, perhaps the problem is in the motherboard and not in the PSU.
 

FamilyGuy

2049 Donator
Donator
Registered
May 31, 2019
345
337
63
AGName
-=FamilyGuy=-
AG Join Date
March 3, 2007
I checked that before and the capacitors seems to be in right polarity. The thing is, when I turn on the console and I measure the 3.3v rail from the psu to the motherboard, it shows in my tester 11.3 mV aproximately... my question is, should the 3.3v rail supply 3.3v all the time? or should it only supply that voltage when it's under charge? if so, perhaps the problem is in the motherboard and not in the PSU.
Voltage sources supply a constant voltage, the current adjusts itself depending on the load. The voltage will only drop if the load is too high and the source can't keep up.

If you see less than approximately 3.3V it means that there's a problem.
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
Voltage sources supply a constant voltage, the current adjusts itself depending on the load. The voltage will only drop if the load is too high and the source can't keep up.

If you see less than approximately 3.3V it means that there's a problem.

I remember that before the recap, both 5v and 3.3v leds on the motherboard turn on but now only the 5v turns on. Perhaps the PSU is not the problem after all, I'm completely sure that I welded all the caps well. Also, From 43 SMD caps replaced, 35 were beginning to leak electrolithic. For my luck, there is no corrosion on the board. Any tip?
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
Also, the SMD capacitors were replaced by this type of capacitors:

F7567686-01.jpg


Of course that I checked that the uF values were correct in every capacitor, some capacitors support more voltaje than the original SMD ones but I suppose that's not a problem.
 

FamilyGuy

2049 Donator
Donator
Registered
May 31, 2019
345
337
63
AGName
-=FamilyGuy=-
AG Join Date
March 3, 2007
Also, the SMD capacitors were replaced by this type of capacitors:

F7567686-01.jpg


Of course that I checked that the uF values were correct in every capacitor, some capacitors support more voltaje than the original SMD ones but I suppose that's not a problem.
Did the original SMD caps had a polarity?

Those big electrolytic capacitors are polar whereas a lot of small SMD ones that look like SMD resistors aren't. Big SMD caps that have a cylindrical part should be ok though, but triple-check the polarity.

Depending on the function of the capacitor, it might not be possible to replace it with a polar equivalent.

You could test your PSU by powering other 3.3V stuff with it. An old 3.3V fan should be ok.
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
Did the original SMD caps had a polarity?

Those big electrolytic capacitors are polar whereas a lot of small SMD ones that look like SMD resistors aren't. Big SMD caps that have a cylindrical part should be ok though, but triple-check the polarity.

Depending on the function of the capacitor, it might not be possible to replace it with a polar equivalent.

You could test your PSU by powering other 3.3V stuff with it. An old 3.3V fan should be ok.

Yes, the SMD replaced capacitors had polarity, an example:

e-cap-smd-5.jpg


But as you said before, I'll check again the polarity on all the boards. Good idea, I can test the katana psu on another computer. The thing is, perhaps the katana's psu is not generic after all and it sends a modified signal that all early ATX psu doesn't send.
 

FamilyGuy

2049 Donator
Donator
Registered
May 31, 2019
345
337
63
AGName
-=FamilyGuy=-
AG Join Date
March 3, 2007
Yes, the SMD replaced capacitors had polarity, an example:

e-cap-smd-5.jpg


But as you said before, I'll check again the polarity on all the boards. Good idea, I can test the katana psu on another computer. The thing is, perhaps the katana's psu is not generic after all and it sends a modified signal that all early ATX psu doesn't send.
That's why I suggested a 3.3V fan, just plug it in and there's no real risk.
 

karlmartin95

Member
Original poster
Registered
May 31, 2019
22
17
3
That's why I suggested a 3.3V fan, just plug it in and there's no real risk.

I didn't tell you before, but this PSU cannot be tested with a simple "bridge hack" like the most ATX PSUs...

Example:
dde40555-1b01-4945-88e9-a6aa8f7e9b27.jpg


So the only way to test it is connecting the PSU to the Katana.
 

Another fundraiser..

This fundraiser is multiple lots we have been offered for our museum, most of these are extremely early systems, and many contain unreleased games and history that would other wise be lost.

The goal for this is split into groups, we have awhile to sort this one and lots would be paid as funded. The total includes paypal fee's added and shipping costs included excluding taxes, we put 10% as we're often charged different rates depending on donators locations.
Goal
£3,570.00
Received
£1,166.36
Latest donor
MSX MSX
32%
Custom LBP Developer PS3 containing multiple unreleased games, and multiple alpha builds.
£1,300.00
An early prototype PlayStation 3 dev Kit, in an early shell design which includes a disc filled with build(s? exact contents unknown)
£1,230.00
Misc Nintendo systems.
£500.00
The above prices doesn't include paypal fees, please see goal amount for total with 10% added for fee's we're charged.
£0.00
Expenses