Unreleased console from the big THREE

We're urgently fundraising for an unreleased games console from the big three game companies.

There is less than 5 of these known to exist, and we have the chance to secure one and document it on our new channel.

All data/software found on the system will be shared with researchers, but donators will get first access. High res 4k video will be done on the device and it's internals for future reference.

This fundraiser is time sensitive.
Goal
£2,000.00
Received
£2,071.00
Welcome, Guest!

Here are some links you may find helpful

Sega Katana Set4 "Failed to load full stub"

Jackhead

Well-known member
Original poster
Registered
May 31, 2019
233
419
63
AGName
Jackhead
AG Join Date
April 3, 2008
Im still try to get my Set4 Devkit up and running. I got great help from a member here. We did some tests, swapping the bios, recapp caps, resistors and so on.
But i still have problems with the DA Check. So we started using the debug port of the Cross emulator board to get more information out of the Kit.
So what i got with putty is :

DA Boot

Configure BSC
Configure cache
Test DRAM
Call main()
Flash Protection Check
Manufacturer Code = 04, Device Code = a4

RELEASE VERSION
Version : 3.4.0a
Built : Jul 22 1998, 08:39:03
Product ID : KATANA
Model ID : DEBUG ADAPTER
SerialNumber : pcch20795
Test Date : 1998-07-27


Running idle process
Start 1k load
1K stub loaded.
Console BIOS started.
Waiting for response from the console.........
Failed to load full stub.
1K stub loaded and running.
Press ? for menu.

So when i start the Kit with my dev PC the cross board is booting fine on the scsi interface. With the DA Check both sides failed the test.
Im not sure what stub the 1k is, and what stub failed to load. For me it looks like the cross board is operating correctly, it stops when it send a call to the Katana board.
Just wonder someone can jump in with some knowledge maybe?
The output data is when i start the kit.
 

Ioncannon

Active member
Registered
Jun 25, 2019
36
24
8
AGName
Ioncannon
AG Join Date
Oct 19, 2010
Sounds like the top board (the console board) isn't working? Tried checking the capacitors?

Btw did you figure out the input pin and encoding for that port? Could never get the menu to appear.
 

Unreleased console from the big THREE

We're urgently fundraising for an unreleased games console from the big three game companies.

There is less than 5 of these known to exist, and we have the chance to secure one and document it on our new channel.

All data/software found on the system will be shared with researchers, but donators will get first access. High res 4k video will be done on the device and it's internals for future reference.

This fundraiser is time sensitive.
Goal
£2,000.00
Received
£2,071.00