Welcome, Guest!

Here are some links you may find helpful

Saturn Sega Saturn NTSC model 2 no color?

Capt. 2110

Member
Joined
Jul 31, 2019
Messages
11
Reaction score
0
Points
1
Hi! I bought a broken Saturn for $15 a couple of days ago, and now that I have everything I need to use it, I found it had two issues:
1. The games were only recognized as CDs.
2. The screen is in black and white on both a modern Sony LCD TV and my PVM-1341.

Problem one was easy enough to fix (turn the knob on the back of the laser very slightly until it works), but problem 2 has me stumped. I'm using a composite cable, and I've checked the cable for shorts (none that I could find), I've cleaned the board with 91% isopropyl alcohol, I've checked the voltages (3.38, 5.10, and 9.10 idle, 3.35, 5.08, 8.75 at lowest), and I've looked for leaking capacitors (none that I could see, but I know they can fail without leaking, and I intend to recap the system later anyway.) The 9V line concerns me, but I don't think it should effect this that much. Any ideas on how to fix the issue? Thank you!
 

Rawit

Member
Joined
Jun 13, 2019
Messages
6
Reaction score
2
Points
3
AG User Name
Rawit
AG Join Date
May 24, 2005
I would check the CXA1645. Sounds like you're only getting luminance and missing the chrominance subcarrier. Check if pushing it changes the signal.
 

Capt. 2110

Member
Joined
Jul 31, 2019
Messages
11
Reaction score
0
Points
1
Sadly it didn’t change anything pushing on it, but maybe something after the chip is stopping the signal? I looked at a simple diagram of the basic circuit and saw its essentially a capacitor and resistor tied to the rest of the circuit, so maybe one of those went bad?
 

Rawit

Member
Joined
Jun 13, 2019
Messages
6
Reaction score
2
Points
3
AG User Name
Rawit
AG Join Date
May 24, 2005
Could be. Those are also simpler to test or replace than the video encoder. You also might want to take a look at pin 6, this the pin for subcarrier input.

Datasheet CXA1645
 

Druid II

Well-known member
Registered
Joined
Jun 5, 2019
Messages
98
Reaction score
62
Points
18
Measure IC21 pin 6 for frequency and pin 7 for voltage. Should be 3.58MHz and +5V for NTSC, and 4.43MHz and GND for a PAL console. If you have a mismatch the chip will either generate pal-60 or ntsc-50, or won't generate any colour subcarrier at all.

Pin 6 comes from IC20 pin 28 directly, I think. If you can't measure frequency, at least check if there is continuity between them.

Or just use the RGB output. Or the S-Video.
 

Capt. 2110

Member
Joined
Jul 31, 2019
Messages
11
Reaction score
0
Points
1
I finally have some time to work on this again! According to my scope, both pin 28 of IC20 and pin 6 of IC21 are putting out 60HZ at about 90 Volts, so I'm guessing I'm doing something wrong (I'm somewhat new to using my scope), but there also appears to be no continuity between the two pins, so I'm not sure what could be happening there. Pin 7 of IC21 has 5V DC on it, so it should be set to NTSC, so I've got that going for me. Any advice on where to go from here? Thanks!
 

Capt. 2110

Member
Joined
Jul 31, 2019
Messages
11
Reaction score
0
Points
1
So I figured out my oscilloscope issues, and found both ICs are connected, but there's a ~3.3V, 100 HZ signal from pin 28 of IC20 leading to pin 6 of IC21. What would be messing up the origin of the signal? As a side note in case it's important, IC20 has a pin labeled test. It's pin 4. If I put my scope on it it's a solid 5 volts, which seems off for a test pin. I really hope IC20 isn't bad.

Edit: So I tested pins 6, 7, 10, and 25 on IC20 (EXTCLK, OSCSW, OSIN2, and OSIN1). EXTCLK and OSCSW and at 0 volts with no signal (grounded maybe?), OSIN2 has a steady 5 volts, and OSIN1 is ~4 volts at 100 Hz. So maybe whatever drives OSIN1 is bad? According to page 12 of the service manual for the VA0 (mine is a VA2 but a VA2 service manual hasn't seemed to show up yet), clock 2 isn't used, so that could explain the +5 on OSIN2, but clock 1 is supposed to be 14.318MHz, and OSIN1 is definitely not that. So maybe the core clock generator circuit is bad?
 
Last edited:
shape1
shape2
shape3
shape4
shape5
shape6
Top