Welcome, Guest!

Here are some links you may find helpful

Turbografx16 Turbografx express rgb + av mod :)

somacast

Registered
Registered
Joined
Jul 13, 2019
Messages
29
Reaction score
4
Points
3
AG User Name
somacast
Hi , I am back to my hobby (electronics) after a loong 3 months stop..?

I guess some of you might already remember that I posted a few threads in AG about problems I faced during my mod, which is LCD , AV chip (obey 3) and RGB-scart out + AV out in one cable, the external controller port as well, all works , but ....

if i connect the internal controller board, the picture via RGB out fades out (washed colors) after a few minutes , only happens when the controller board is connected, and by just switch console on and off colors comes back, fades again in minutes, and so in.

disconnected the controller board ribbon cable, and it worked for hours with even both internal lcd working and rgb scart display working..

when i connect it, internal controller works, sound works, external controller works, but colors fade in rgb scart after about 5 -6 minutes..

tried recapping (again) , tried disconnecting power to (obey) AV chip maybe it was conflicting , even altered the v501 to increase or decrease voltage, then even replaced v501, nothing had effect, except removing board cable.

any thoughts please? its driving me crazy ?

thanks in advance
 

somacast

Registered
Registered
Joined
Jul 13, 2019
Messages
29
Reaction score
4
Points
3
AG User Name
somacast
those are the faded and normal pics
 

Attachments

  • 20190713_232916.jpg
    20190713_232916.jpg
    2.8 MB · Views: 0
  • 20190713_233648.jpg
    20190713_233648.jpg
    3.2 MB · Views: 0

somacast

Registered
Registered
Joined
Jul 13, 2019
Messages
29
Reaction score
4
Points
3
AG User Name
somacast
also tried right now : after screen was faded I removed the controller board cable (while console is on) and colors comes right away !!

putting it back still while console is on colors remains, but fades up as usual after few minutes...

i think this problem was there even before fixing the diodes for the controller mod ...
 

somacast

Registered
Registered
Joined
Jul 13, 2019
Messages
29
Reaction score
4
Points
3
AG User Name
somacast
any technical information might be helpful

what causes the colors to fade/fail in rgb mode ? the problem is within the console, i tried 2 different rgb chips,same results, removing the cable of controller board restores the colors

what is the function of hu chip 6280? is it failing after 5 minutes ? is there a contradiction between external controller port mod and rgb mod ??

thanks ..?
 
shape1
shape2
shape3
shape4
shape5
shape6
Top