Welcome, Guest!

Here are some links you may find helpful

I and II buttons stopped working on Turbo Express, will pay $$ for fix

Hawanja

Well-known member
Joined
Aug 3, 2019
Messages
45
Reaction score
11
Points
8
AG User Name
Hawanja
AG Join Date
March 14, 2004
Howdy folks. So I have a Turbo Express, like the title says the I and II buttons stopped working. The unit powers up, game plays fine. Run button works, crosspad works. About 8 years ago I paid a guy on the old Assembler boards to put some new caps on it and such because the screen wasn't turning on anymore, I assume this is the same kind of problem.

Anyway, if someone wants to make a quick $50, I'll pay you to fix it. I have no idea about the innards of these things myself (I wouldn't trust myself to not make it worse.) If you're interested send me a PM and we'll talk.

Thanks.
 

Nully

Donator
Donator
Joined
Sep 14, 2019
Messages
110
Reaction score
54
Points
28
AG User Name
lh
AG Join Date
2010
If I were you, I would message one of the people who specialize in repairing them on eBay or some other marketplace.
 

Tokimemofan

Well-known member
Registered
Joined
May 30, 2019
Messages
83
Reaction score
26
Points
18
This problem has 2 different causes, the contacts for the turbo switch are dirty or or the printed carbon resistors are bad. About half the units i have serviced recently have had one of those problems. I used some wire and a surface mount resistor to bypass the latter problem with good results. Yet another problem this things have.
 
shape1
shape2
shape3
shape4
shape5
shape6
Top